2 SPEED HIGH LOW

AA Ford Discussion Group relating to the repair and restoration of your AA Ford.
Post Reply
buddy
Posts: 17
Joined: March 13th, 2016, 2:03 pm
Body Type: AA flatbed
Model Year: 1929

2 SPEED HIGH LOW

Post by buddy » September 16th, 2017, 7:20 am

My 29AA has a pedal operated 2 speed high low box. the truck has been stored inside for over 30 years and never driven. i recently got it running and drove it out of the shop. The 2 speed pedal will not engage when you push down on the back. Can't remember if thats the high or the low. the gears makes a makes a grinding noise and wont engage. it works fine in the front position, no grinding, i don't remember ever having this problem years ago when i drove it. any suggestions or thoughts???

I bought the truck when I was 15 years old in 1970!

User avatar
1crosscut
Posts: 699
Joined: December 25th, 2010, 7:22 pm
Body Type: 82-A
Model Year: 1929
Location: Lincoln, NE

Re: 2 SPEED HIGH LOW

Post by 1crosscut » September 16th, 2017, 9:32 am

Front down is high. Perhaps your floor board has shifted or such and is preventing the pedal from moving full travel.

Glad your getting the truck out and on the go again.
------------
Dave

buddy
Posts: 17
Joined: March 13th, 2016, 2:03 pm
Body Type: AA flatbed
Model Year: 1929

Re: 2 SPEED HIGH LOW

Post by buddy » September 16th, 2017, 4:45 pm

Thanks! ill try that, hope it works/easy fix!

User avatar
Chris Haynes
Posts: 1906
Joined: September 7th, 2003, 5:18 pm
Body Type: 82A
Model Year: 1930
Location: North Hills, CA/ Pine Grove, CA

Re: 2 SPEED HIGH LOW

Post by Chris Haynes » September 18th, 2017, 12:48 pm

It is not High/Low. It is Direct/Low.

Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests