Coolant system question!

AA Ford Discussion Group relating to the repair and restoration of your AA Ford.
User avatar
1crosscut
Posts: 814
Joined: December 25th, 2010, 7:22 pm
Body Type: 82-A
Model Year: 1929
Location: Lincoln, NE

Re: Coolant system question!

Post by 1crosscut » August 12th, 2019, 5:15 pm

KVO if your water is at 245 I wouldn't be running it until I figured out what is wrong. Since you have a new radiator I would be looking at your timing to see if it is very retarded. Have you had the head off to see if the water passages are clogged with rust or grease?
------------
Dave

cokefirst
Posts: 26
Joined: May 16th, 2013, 10:13 am
Body Type: stake
Model Year: 1931

Re: Coolant system question!

Post by cokefirst » August 14th, 2019, 3:13 pm

My AA used to spit water on warm days and I was always adding to it. I just did a restoration refresh, put in a new Brassworks radiator and decided to use Evans waterless coolant. So far, I love it. No spitting and it has a boiling point of 325 degrees. It is non corrosive. The cost is expensive, but it never has to be replaced unless you lose a hose.

KimVanOrder
Posts: 594
Joined: August 11th, 2013, 4:25 pm
Body Type: 82-A Platform
Model Year: 1928
Location: Hamilton, Mich.

Re: Coolant system question!

Post by KimVanOrder » August 14th, 2019, 4:34 pm

1crosscut wrote:
August 12th, 2019, 5:15 pm
KVO if your water is at 245 I wouldn't be running it until I figured out what is wrong. Since you have a new radiator I would be looking at your timing to see if it is very retarded. Have you had the head off to see if the water passages are clogged with rust or grease?
Dave. I have not had the head off,,,, Yet!!!.. Sounds like a project for this fall. I have been driving it every day, and the boiling seems to be under control. Any one know of a cleaner that i could use? Something that will cut the rust..

KVO
KVO
Dec. '28 AA

Post Reply