Rough week and update on the AA

AA Ford Discussion Group relating to the repair and restoration of your AA Ford.
Post Reply
User avatar
rrich1
Posts: 27
Joined: December 29th, 2018, 4:02 am
Model Year: 1931

Rough week and update on the AA

Post by rrich1 » October 29th, 2019, 11:18 pm

This past week my grandfather who previously owned the AA passed away Friday. He was 88 and suffered from Alzheimer's for the past 9 years. My grandma asked if I could have the truck at his celebration of life this saturday. Of course even if I had to push the truck there. I had been trying to diagnose the issues with the truck but was stuck, crank no start, or short rough running and die and not able to get it going again. Well a few of my model A club members came over and really helped me out.

First off there was sediment found in the carb. I took the carb off before but dont remember seeing sediment in there then. One of the members rebuilt the carb and flow tested it and got it back to me. I ordered the late '31 in line filter kit and will be here later today. Also ordered 4 filters from NAPA. I plan to try and drain the pan and clear out some of the debris that was coming out of the line.

Second the intake gasket was leaking so we replaced it.

Third the distributor was giving us issues. Mine had a modern plate on it w a dummy condensor. Replaced it with a brand new unit w original style points that one of the members had and it runs a whole lot smoother . T

Fourth, three out of four cylinders are low on compression (30lbs) with the fourth being at 60. Put some MMO in it to hopefully loosen up some stuck valves. Even with the low compression it ran extremely smooth.

A loaner starter was lent to me a while ago while mine got looked at. The business put a modern bendix on mine but I think the shaft is bent. When I put mine back on it didn't sound right and sounded like something was off. The loaner starter has been put back on for now.

I have not started the truck since they left on saturday with their auxiliary tank. I plan to try again today after I get the new filter kit on and shake out the loose bits.

We didn't get to it on Saturday but my horn and lights are currently not working either. The horn did ahooga once but was very subdued but havnt gotten it to works since. The light bulbs are good. Ill have to find that issue here soon so I can drive it with brake lights.

KimVanOrder
Posts: 597
Joined: August 11th, 2013, 4:25 pm
Body Type: 82-A Platform
Model Year: 1928
Location: Hamilton, Mich.

Re: Rough week and update on the AA

Post by KimVanOrder » October 30th, 2019, 3:29 pm

God bless you and your family in this time of morning. It's great your doing what your doing.. Many have already enjoyed what your doing :D ..
KVO
Dec. '28 AA

vonheine
Posts: 77
Joined: September 30th, 2009, 8:02 pm
Body Type: none
Model Year: 1930
Location: Massachusetts

Re: Rough week and update on the AA

Post by vonheine » October 31st, 2019, 3:12 pm

My sincere condolences to you and your family. Great to hear about everyone pulling together to get your truck going better.

Post Reply